POJ - 3624 Charm Bracelet

jlqwer 发表于 代码 分类,标签:
  • Bessie has gone to the mall's jewelry store and spies a charm  bracelet. Of course, she'd like to fill it with the best charms  possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the  charms with their weights and desirability rating, deduce the maximum  possible sum of ratings.

  • Input

  • * Line 1: Two space-separated integers: N and M
    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

  • Output

  • * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

  • Sample Input

  • 4 6 1 4 2 6 3 12 2 7
  • Sample Output

  • 23
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
    int N,M,W[3500],D[3500],dp[3500];
    while(cin>>N>>M)
        {
            for(int i=0;i<N;i++){
                scanf("%d%d",&W[i],&D[i]);
        }
        memset(dp,0,sizeof(dp));
        for(int i=0;i<N;i++)
        {
            for(int j=M;j>=W[i];j--)
            {
                dp[j]=max(dp[j-W[i]]+D[i],dp[j]);
            }
        }
        cout<<dp[M]<<endl;
    }
    return 0;
}